Issue
One of the following errors occurs during Imunify360 registration or installation:
WARNING: License is invalid for current server
WARNING: License is invalid for this server
Registration was not successful. Exiting.
Imunify360 requires a different license type based on the number of users registered on the server.
How can I count how many users currently exist on the server?
Environment
- cPanel
- Imunify360
- Plesk
- DirectAdmin
- CyberPanel
- No hosting panel systems
- CLN
Resolution
Please, refer to What does "user" mean when buying a license? Types of licenses to get more information about users before counting them.
-
cPanel
To count users, run the following command:
# grep -Po '^(?<!#)\s*\w+\s*(?=:)' /etc/userplans | wc -l
Also, it may be useful to list users. To do so, run the following command:
# cut -d":" -f1 /etc/userplans | sort -n | uniq
-
Plesk
To count users, run the following command:
# plesk db "SELECT COUNT(DISTINCT cl_id) FROM domains"
-
DirectAdmin
To count users, run the following command:
# cut -d":" -f2 /etc/virtual/domainowners | sort -n | uniq | wc -l
Also, it may be useful to list users. To do so, run the following command:
# cut -d":" -f2 /etc/virtual/domainowners | sort -n | uniq
-
No hosting panel systems
To count users, run the following command:
# cat /etc/passwd
By default, Imunify360 will use Linux system users, limited by
uid_min
anduid_max
from the/etc/login.defs
. -
CyberPanel
You can check the number of users using the method for servers without the control panel (check the above option). CyberPanel creates a new user for each "website", and doesn't create a user for additional "domain" inside "website".
-
The number of users matches the license.
If the number of users matches the license, but registration fails due to an error, it is necessary to run the command:# imunify360-agent update-license
And then, register the server again.
Cause
The error message received during the license key registration means the number of users on the server exceeds the user limit provided for the Imunify360 subscription purchased. Also, this error may occur when activating the ImunifyAV license with Imunify360 installed.
Comments
2 comments
A "License is invalid for current server" might also be te case for the sceario when the same IP was previsously used for another trial
Hello, I tried everything in this article but it still would insist the license was not valid.
So in a last ditch effort I re-ran the install process:
Strangely it mentioned twice while installing that the key was not valid for the server, but once fully re-installed it has indeed worked now.
I believe the cause was remnants of AV+ still existing, this server used to use AV but it was supposed to be removed when we setup and installed i360 for 30-day trial.
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