Symptoms
The attempt to scan the account fails with the following error:
# imunify-antivirus malware malicious cleanup --user jdoe
ERROR: Feature 'av' is disabled for user 'jdoe'
Cause
The ImunifyAV/360 feature is disabled for the user.
Resolution
For Imunify360 customers: please click here and check if the option is enabled for the user.
For ImunifyAV customer:
Enable the feature for the user:
# imunify-antivirus feature-management enable --feature av --users jdoe
The feature can be enabled by default for all newly created users as follows:
# imunify-antivirus feature-management enable --feature av
In order to enable the feature for all existing users in DirectAdmin, use the following command:
# cut -d":" -f2 /etc/virtual/domainowners | sort -n | uniq | xargs imunify-antivirus feature-management enable --feature av --users
In order to enable the feature for all existing users in cPanel, use the following command:
# cut -d":" -f1 /etc/userplans | sort -n | uniq | grep -v "userplans v" | xargs imunify360-agent feature-management enable --feature av --users
Additional information
Cleaning is performed on behalf of the system user of the account. I.e., the scanning of files owned by the user jdoe will be performed under the identity of the user jdoe, even if executed by root.
Therefore, it is mandatory to grant it permission.
Permission can be reverted after the malware cleanup:
# imunify-antivirus feature-management enable --feature av --users jdoe
# imunify-antivirus malware malicious cleanup --user jdoe
# imunify-antivirus feature-management disable --feature av --users jdoe
Comments
0 comments
Please sign in to leave a comment.