Issue
The scanning process initiated with ImunifyAV (ex. Revisium) fails with the status "Failed to Scan"
Environment
ImunifyAV (ex.Revisium) on Plesk servers.
Solution
Increase the scanning timeout parameter in the ImunifyAV extension settings:
1. Go to Plesk > Extensions > ImunifyAV > Settings tab;
2. Find the parameter "Scanning timeout" and try to change it to "24 hours" or "Unlimited":
3. Click on the "Ok" button to apply the changes.
As another cause it can be incorrect permissions:
It can be checked in the logs
/usr/local/psa/var/modules/revisium-antivirus/revisium-antivirus-local.log
Be sure that this folder has incorrect permissions. If not (usually, it can be root:root) - it should be changed it. 'username' must be replaced with a real username.
chown username:psacln /var/www/vhosts/123.com/.revisium_antivirus_cache -R
Cause
In most cases, the site is large, and the scan was terminated due to timeout or incorrect permissions were set.
Useful links
- https://docs.imunifyav.com/imunifyav_for_plesk/#explaining-the-settings-tab
- https://docs.imunifyav.com/imunifyav_for_plesk/#dashboard-says-scan-failed-with-no-related-error-message
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