Issue
On a server with Imunify360, KernelCare patches cannot be installed and the KernelCare license cannot be verified due to errors:
# kcarectl --license-info
No valid key-based license found
# kcarectl -u
Downloading updates
HTTP Error 403: Forbidden: https://patches.kernelcare.com/...
Environment
- Imunify360
- KernelCare
- Any OS
- Any panel
Solution
-
It is necessary to check if there is a separate file on the server, from which KernelCare gets the incorrect server ID. If there is such a file, it should be moved temporarily:
# cat /etc/sysconfig/kcare/systemid
server_id=SSABCDEabcde123
# mv /etc/sysconfig/kcare/systemid /etc/sysconfig/kcare/systemid_bkp -
It should be checked if the set-patch-type is set correctly:
# kcarectl --set-patch-type default
# kcarectl --updateNote: When the "systemid" file is missing, KernelCare checks if there is a suitable license for Imunify360 available:
7046 08:15:48 stat("/etc/sysconfig/kcare/systemid", 0x7ffc7dd9fbb0) = -1 ENOENT (No such file or directory) <0.000035>
7046 08:15:48 stat("/var/imunify360/license.json", {st_mode=S_IFREG|0600, st_size=1675, ...}) = 0 <0.000027>
7046 08:15:48 open("/var/imunify360/license.json", O_RDONLY) = 4 <0.000028>If so, KernelCare works as expected:
# cat /etc/sysconfig/kcare/systemid
cat: /etc/sysconfig/kcare/systemid: No such file or directory
# kcarectl --license-info
Key-based valid license found -
If this does not help, please, create the ticket at our helpdesk.
Cause
From a separate file, the kcarectl gets the incorrect server ID, and cannot get updates or license information.
Comments
2 comments
Should we restore the /etc/sysconfig/kcare/systemid in place after this operation?
mv /etc/sysconfig/kcare/systemid_bkp /etc/sysconfig/kcare/systemid
Need to add a mv command to Solution Step 1.
Also, this post says move the systemid file temporarily but, if the procedure restores KC, what is supposed to be done with the systemid file? Is it supposed to be restored or deleted or what?
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