Issue
The following errors occur:
The system cannot check the kernel status:
"/usr/bin/yum" reported error code “1” when it ended:
Error: Cannot open file "/var/cache/dnf/cloudlinux-x86_64-server-8-ec8365a17697c700/repodata/fc83645d800ccd374b605e376d74317b0286f67263b266eacf538ae954593f46-modules.yaml.gz":
No such file or directory "/usr/bin/yum" reported error code "1" when it ended:
Error: Cannot open file "/var/cache/dnf/cloudlinux-x86_64-server-8-ec8365a17697c700/repodata/fc83645d800ccd374b605e376d74317b0286f67263b266eacf538ae954593f46-modules.yaml.gz":
No such file or directory
Environment
- CloudLinux
- cPanel
Solution
1. Clean and re-create cache:
# yum clean all
# yum makecache
2. Run the update:
# yum update
| NB! If the `yum update` transaction operates as expected, the server might be experiencing connectivity issues with our mirrors. We recommend contacting your datacenter for further investigation. |
Cause
Related to the Spacewalk plugin. If the plugin is enabled, /scripts/maintenance will trigger security advisor warnings about not being able to check the kernel, and this doesn't happen with the plugin disabled.
CloudLinux still uses the plugin - for now, but not for much longer, as we are currently migrating away from it. Thus, it is safe to disable the Spacewalk plugin:
[root@damson ~]# grep enabled /etc/dnf/plugins/spacewalk.conf
enabled = 0
[root@damson ~]# grep enabled /etc/yum/pluginconf.d/spacewalk.conf
enabled = 0
Comments
0 comments
Please sign in to leave a comment.