Issue
The "Kernel is unsupported" error / warning message shows up in the KernelCare tab in Imunify360 interface
Environment
- Imunify360
Solution
A. Example for kernel 3.10.0-962.3.2.lve1.5.64.el7:
The matter is that your kernel has been released just recently as per https://blog.cloudlinux.com/beta-cloudlinux-os-7-and-cloudlinux-os-6-hybrid-kernel-updated, and there are no patches available for it yet since no vulnerabilities have been discovered in that kernel yet, therefore that message can be safely disregarded.
As soon as there are patches available for your kernel and it gets listed in the https://patches.kernelcare.com the reported message will eliminate.
B. To remove the warning you can add the following to the /etc/sysconfig/kcare/kcare.conf file:
IGNORE_UNKNOWN_KERNEL=True
but that's not recommended.
Cause
The kernel was released just recently (like a month or so ago), and there are no known vulnerabilities in it yet - to verify, go to https://changelog.cloudlinux.com/ and https://patches.kernelcare.com.
NB!
Imunify360 looks at kernels available at the production kernels feed as per listed at https://patches.kernelcare.com
It doesn't detect kernels yet in the test, so if you are using test builds instead of production builds IM360 UI will still show the new kernel is unsupported, the kernels coming from are skipped for IM360 UI:
grep PREFIX /etc/sysconfig/kcare/kcare.conf
PREFIX=test
As soon as the kernel is moved to stable the UI message will disappear.
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