Issue
- ClamAV cannot be used DirectAdmin servers without additional configuration
- DirectAdmin started to use system/repo clamav service having
clamscan
located in/usr/bin/clamscan
, so it won't be/usr/local/bin/clamdscan
anymore.
Environment
- DirectAdmin PRO pack
- Cloudlinux
- CageFS
- ClamAV
Solution
Rebuild DirectAdmin as follows:
# /usr/local/directadmin/custombuild/build set clamav yes
# /usr/local/directadmin/custombuild/build clamav
After that, the ClamAV option should be visible in user level to do the scan.
Note: This feature is available only in DirectAdmin licenses with a propack, lifetime licenses or dc licenses does not have that feature.
Cause
When DA starts the ClamAV service – it starts it under a user that does not have the ClamAV binaries in his cage. DA started to use system/repo clamav service, so it won't be '/usr/local/bin/clamdscan' anymore.
The issue registered with id CAG-1276. Once it will be fixed, changes will be reflected in CloudLinux Changelog
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