Issue
As of today our remote WHMCS is unable to communicate with our cPanel servers.
If a user tries to one click login to cPanel OR we try to do a password reset/package reset from WHMCS we will get this error in WHMCS
cPanel API Unreachable: <html> <head><title>415 Unsupported Media Type</title></head> <body> <center><h1>415 Unsupported Media Type</h1></center> <hr><center>openresty/1.27.1.1</center> </body> </html>
the fix is to login to each WHM > Imunify360 > firewall and whitelist the WHMCS Server IP
This only started today and effecting all of our cPanel servers.
the workaround fixed the issue but i wanted to bring this to your attention.
Environment
- cPanel
- Imunify360
Solution
This can be resolved by adding the WHMCS server IP address to the Imunify360 white list. Use the below command.
imunify360-agent ip-list local add --purpose white 11.22.33.44 --comment "one good IP"
Replace 11.22.33.44
with actual IP address.
Cause
Internal bug id DEF-33276
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