Issue
After installation, the Imunify UI is missing in the supported control panel interface.
Environment
- Imunify360
- ImunifyAV
- Supported panels
Solution
It is necessary to ensure that the relevant UI plugin package is installed correctly by reinstalling it. For example, on CentOS, the commands are:
1. As a general case for supported panels and OSes the below command will enable the plugin:
imunify360-agent enable-plugin
2. With cPanel to get packages re-installed the below commands are for Imunify360 and ImunifyAV respectively:
yum reinstall imunify360-firewall-cpanel
yum reinstall imunify-antivirus-cpanel
- on DirectAdmin for Imunify360 and ImunifyAV respectively:
yum reinstall imunify360-firewall-directadmin
yum reinstall imunify-antivirus-directadmin
- on Plesk for Imunify360 and ImunifyAV respectively:
yum reinstall imunify360-firewall-plesk
yum reinstall imunify-antivirus-plesk
Reinstallation should restore the plugin's UI for the supported panel. Please note in some cases, the issue can be within the outdated cache, try the anonymous tab or Disable the cache in browser Developers Tools.
Cause
Prior the version 7.2, the UI was delivered with the imunify-antivirus
package, while imunify360-firewall
doesn't have UI files. It is one of the recent reasons for Imunify360 not having UI, although there might be other issues with packages and these general instructions also aim to address some of these common issues with UI.
Links
- Imunify360 is installed but the UI shows the ImunifyAV logo
- How to reinstall Imunify360 extension in Plesk?
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